Spectrum Outage - Ohio

Incident Report for Accent

Resolved

This incident has been resolved.
Posted Jun 20, 2024 - 20:08 EDT

Monitoring

We have been informed by Spectrum of an ongoing outage affecting both Broadband and Fiber customers within the Ohio region. This may cause intermittent internet connectivity issues, impacting your ability to connect with our services. Our services remain unaffected.

We are closely monitoring the situation and will provide updates as needed to assist our affected customers. If you need number forwarding implemented due to this outage, please reach out to our support team for assistance.
Posted Jun 20, 2024 - 07:08 EDT